problem installnig latest build supported in expired subscription

Posts   
 
    
Kristof V
User
Posts: 3
Joined: 29-Dec-2022
# Posted on: 29-Dec-2022 14:16:10   

Hi,

Our subscription ended on 17/8/2022 and are looking to see if a renewal is feasible (we use nHibernate and I understand this will be deprecated) In the meantime I wanted to install the latest supported version which would be 5.9.2 as it was built in 7/2022, yet it says it is not supported because the built is from 11/2022 ?!

Am I doing something wrong or is there something lingering due to installing 5.9.3 before this which reminded me of the expired licenses, uninstalled it and tried 5.9.2 afterwards ? v5.91 seemed that have the correct built date and I could install that one but would love to install 5.9.2.

Kind regards, Kristof

Walaa avatar
Walaa
Support Team
Posts: 14961
Joined: 21-Aug-2005
# Posted on: 29-Dec-2022 19:43:41   

yet it says it is not supported because the built is from 11/2022

Where do you see that?

Kristof V
User
Posts: 3
Joined: 29-Dec-2022
# Posted on: 29-Dec-2022 21:29:53   

When I install v5.9.2 and start the software, the message says that is is not within my subscription because it was built in november 2022. I downloaded it via My Account -> downloads -> v5.9 where 5.9.2 is the lastest and 5.9.3 is not listed due to being outside subscription.

I've added a screenshot with the error message.

Attachments
Filename File size Added on Approval
llblgen 5.9.2 error.jpg 71,315 29-Dec-2022 21:38.41 Approved
Otis avatar
Otis
LLBLGen Pro Team
Posts: 39636
Joined: 17-Aug-2003
# Posted on: 30-Dec-2022 09:20:01   

Kristof wrote:

When I install v5.9.2 and start the software, the message says that is is not within my subscription because it was built in november 2022. I downloaded it via My Account -> downloads -> v5.9 where 5.9.2 is the lastest and 5.9.3 is not listed due to being outside subscription.

I've added a screenshot with the error message.

The error message says the build is from August 29th, which is after your subscription's expiration date. We released 5.9.2 on July 25th, which would be in your expiration date, however we made a mistake with a config file for npgsql so we had to correct that. This was tiny, so we thought simply build the installer again and upload it, however it ran through the build process again to build the installer which ... builds a new exe and as we use the build-date embedded in the exe by the compiler as the date we check on, this caused the problem here. We didn't realize this would increase the build date of the exe as well...

Building this exact build for July 25th is a bit problematic, so we'll extend your subscription till September 1st so you can use 5.9.2.

(edit) I've extended the subscription till September 1st and have resend you the license which contains the new end date. You should have received it by email by now. Could you try that one please?

Frans Bouma | Lead developer LLBLGen Pro
Kristof V
User
Posts: 3
Joined: 29-Dec-2022
# Posted on: 02-Jan-2023 10:12:42   

Otis,

No worries, I understand. I installed the new license and worked like a charm.

Thank you and best wishes for you and the whole team.

PS : Are you guys dropping the support of nHibernate in next versions ? I use nHibernate and like LLBLGen a lot and would love to renew subscription if nHibernate is still actively supported.

Otis avatar
Otis
LLBLGen Pro Team
Posts: 39636
Joined: 17-Aug-2003
# Posted on: 03-Jan-2023 09:59:54   

Kristof wrote:

Otis,

No worries, I understand. I installed the new license and worked like a charm.

Thank you and best wishes for you and the whole team.

You too a great 2023!

PS : Are you guys dropping the support of nHibernate in next versions ? I use nHibernate and like LLBLGen a lot and would love to renew subscription if nHibernate is still actively supported.

It's not dropped, it's like Linq to Sql: no new features are added and we don't update it to match with the latest Nhibernate versions.

Frans Bouma | Lead developer LLBLGen Pro