Home
Help
Register
Log in

Search

 
   Active Threads  

You are here: Home > LLBLGen Pro > Bugs & Issues> Validator ValidateFieldValue when related entity is set.
 

Pages: 1
Bugs & Issues
Validator ValidateFieldValue when related entity is set.
Page:1/1 

  Print all messages in this thread  
Poster Message
Brandt
User



Location:

Joined on:
04-Apr-2007 17:43:03
Posted:
142 posts
# Posted on: 15-Feb-2009 04:37:42.  
I have a quick question.

Lets say I have these two entities

Customer
-------------
CustomerId (pk)
Name


Order
--------------
OrderId (pk)
CustomerId (fk)
etc.

I have a validator class for the OrderEntity which overrides ValidateFieldValue. When I set the CustomerId property of the OrderEntity the ValidateFieldValue method in the validator runs. However when I set the Customer property which in turn sets the CustomerId property, the ValidateFieldValue does not run. Is this intended and why?

Thanks.
Brandt  Top
daelmo
Support Team



Location:
Guatemala City
Joined on:
28-Nov-2005 23:35:24
Posted:
8098 posts
# Posted on: 15-Feb-2009 20:14:18.  
Here is why and some explanation: http://llblgen.com/TinyForum/Messages.aspx?ThreadID=7398

David Elizondo
LLBLGen'ing (articles and code snippets) | linkedin | twitter
 
Top
Brandt
User



Location:

Joined on:
04-Apr-2007 17:43:03
Posted:
142 posts
# Posted on: 15-Feb-2009 20:18:19.  
daelmo wrote:
Here is why and some explanation: http://llblgen.com/TinyForum/Messages.aspx?ThreadID=7398



Thanks, I was sure the reason was out there but my 15 min of searching couldn't find it. Thanks for locating that for me.

Brandt  Top
Pages: 1  


Powered by HnD ©2002-2007 Solutions Design
HnD uses LLBLGen Pro

Version: 2.1.12172008 Final.