CliSyncWithDatabase.exe issue with stored procedure

Posts   
 
    
Posts: 6
Joined: 24-Jun-2022
# Posted on: 15-Mar-2023 19:39:07   

Hi Team, We are using LLBLGen 5.8 to generate the entities for your project. Our database is Oracle 21C. We are facing one issue related database sync. When we try to sync the database from LLBLGen design pro it shows the database model correctly including tables, views and stored procedures. We notice when we add new stored procedure which returns data using cursor and try to sync the procedure by using below command -

CliSyncWithDatabase.exe /u:<id> /p:<password> $useODP $showLogOutput "<projectname>.llblgenproj"

The result in the database model in llblgen project file for this procedure is not showing any resultsets and result set of the procedure is showing zero. We are expecting the resultset of the procedure should be 1 instead of 0.

Kindly provide your feedback for the above query. Thanks!

Otis avatar
Otis
LLBLGen Pro Team
Posts: 39636
Joined: 17-Aug-2003
# Posted on: 16-Mar-2023 09:33:55   

The Cli refresher can't do that task. The user has to select which stored procedures the resultsets have to be determined for. This is an optional task which requires user intervention and it's done in the designer, not on the command line. The reason is that the stored procedure has to be executed (with default parameters and a transaction that's rolled back) which can have side effects in theory (even though the proc is in a transaction that's rolled back) hence we're not automatically discovering this for all procedures in the schema. (it also might be useless for a lot of procs to do so, hence the user should select which ones to pick the resultsets for).

Frans Bouma | Lead developer LLBLGen Pro