Home
Help
Register
Log in

Search

 
   Active Threads  

You are here: Home > LLBLGen Pro > Custom Templates> Small bug testing updating to v5.5 from v4.2
 

Pages: 1
Custom Templates
Small bug testing updating to v5.5 from v4.2
Page:1/1 

  Print all messages in this thread  
Poster Message
simmotech
User



Location:

Joined on:
01-Feb-2006 15:43:00
Posted:
1006 posts
# Posted on: 20-Feb-2019 13:23:54.  
I have a custom template that starts
---
        #region Names
        /// <summary>More names added for consistency of access</summary>
        public static <[If IsSubType]>new <[EndIf]><[If UsePartialClasses]>partial <[EndIf]>class Names
        {
---

But the generated code
------
        // __LLBLGENPRO_USER_CODE_REGION_START CustomEntityCode
        // __LLBLGENPRO_USER_CODE_REGION_END        #region Names
        /// <summary>More names added for consistency of access</summary>
        public static partial class Names
        {
------

It would seem that the first line is appended directly after the REGION_END comment rather than the next line.
  Top
Walaa
Support Team



Location:

Joined on:
21-Aug-2005 16:03:48
Posted:
14520 posts
# Posted on: 20-Feb-2019 21:07:05.  
Is this a Custom_EntityAdapterTemplate ?

  Top
simmotech
User



Location:

Joined on:
01-Feb-2006 15:43:00
Posted:
1006 posts
# Posted on: 20-Feb-2019 22:03:10.  
Walaa wrote:
Is this a Custom_EntityAdapterTemplate ?

Yes - it worked fine in v4.2 but in v5.5 I had to add a blank line at the top to prevent the issue described above.
  Top
Otis
LLBLGen Pro Team



Location:
The Hague, The Netherlands
Joined on:
17-Aug-2003 18:00:36
Posted:
37605 posts
# Posted on: 21-Feb-2019 10:21:56.  
We'll correct it in the next release (5.5.2).

The statements are on the same line to prevent empty lines in the output for the situation where there's no include template (which is usually the case). However it shouldn't be the case where it ruins code with include templates of course.


Frans Bouma
LLBLGen Pro / ORM Profiler Lead Developer | Blog | Twitter
 
Top
Otis
LLBLGen Pro Team



Location:
The Hague, The Netherlands
Joined on:
17-Aug-2003 18:00:36
Posted:
37605 posts
# Posted on: 21-Feb-2019 11:07:51.  
Fixed in next build of 5.5.2. (We'll push a new hotfix soon)
Frans Bouma
LLBLGen Pro / ORM Profiler Lead Developer | Blog | Twitter
 
Top
Pages: 1  


Powered by HnD ©2002-2007 Solutions Design
HnD uses LLBLGen Pro

Version: 2.1.12172008 Final.