Home
Help
Register
Log in

Search

 
   Active Threads  

You are here: Home > LLBLGen Pro > LLBLGen Pro Runtime Framework> All DefineField methods gone after 2.6 upgrade
 

Pages: 1
LLBLGen Pro Runtime Framework
All DefineField methods gone after 2.6 upgrade
Page:1/1 

  Print all messages in this thread  
Poster Message
DaveR
User



Location:

Joined on:
15-Jun-2004 16:37:10
Posted:
43 posts
# Posted on: 21-Aug-2009 18:14:09.  
We just upgraded from 2.5 to 2.6 and found that all of the DefineField() methods from ResultSetFields are not generated.

I found this thread which indicates the signature of the method has changed in 2.6:

http://www.llblgen.com/tinyforum/Messages.aspx?ThreadID=13627&HighLight=1

However, these DefineField() methods do not exist at all.

Apologies if this is an obvious issue but I have not found anything about it in the forum or FAQs. How can we get back the DefineField() methods?
  Top
daelmo
Support Team



Location:
Guatemala City
Joined on:
28-Nov-2005 23:35:24
Posted:
8099 posts
# Posted on: 21-Aug-2009 22:01:39.  
These DefineField method overloads are there. Please make sure you are referencing the correct LLBLGenPro v2.6 assemblies in your projects.

David Elizondo
LLBLGen'ing (articles and code snippets) | linkedin | twitter
 
Top
DaveR
User



Location:

Joined on:
15-Jun-2004 16:37:10
Posted:
43 posts
# Posted on: 21-Aug-2009 22:49:38.  
OK, they're in the runtime libs and not generated code? That would make sense.

Thanks!
  Top
daelmo
Support Team



Location:
Guatemala City
Joined on:
28-Nov-2005 23:35:24
Posted:
8099 posts
# Posted on: 21-Aug-2009 23:10:35.  
Yep. ResulsetFields is part of ORMSupportClasses that is in SD.LLBLGen.Pro.ORMSupportClasses assembly, so you should double check that you are using the correct (v2.6) assembly Regular Smiley

David Elizondo
LLBLGen'ing (articles and code snippets) | linkedin | twitter
 
Top
Pages: 1  


Powered by HnD ©2002-2007 Solutions Design
HnD uses LLBLGen Pro

Version: 2.1.12172008 Final.