Home
Help
Register
Log in

Search

 
   Active Threads  

You are here: Home > LLBLGen Pro > LLBLGen Pro Runtime Framework> 'EntityCollection' could not be set on property 'DataContainerType
 

Pages: 1
LLBLGen Pro Runtime Framework
'EntityCollection' could not be set on property 'DataContainerType
Page:1/1 

  Print all messages in this thread  
Poster Message
like2175
User



Location:
Camberley, United Kingdom
Joined on:
27-Mar-2006 16:16:06
Posted:
83 posts
# Posted on: 04-Nov-2008 11:32:40.  
My page still runs, but now, since restarting my project and not knowingly changing anything, when viewing the design of the page all of the LLBLGenProDataSource controls (self-serv) show:

"Error Creating Control - {control_name}
'EntityCollection could not be set on property 'DataContainerType'.

I've added a new dsOffice and this works fine:
I can't bind any new controls to the "broken" LLBLGenProDataSources

You can see from this extract that the markup is identical for the "broken" dsNotificationType and the working dsOffice:

Can I do anything to "fix" the broken LLBLGenProDataSource controls?

Code:

<llblgenpro:LLBLGenProDataSource ID="dsNotificationType" runat="server" DataContainerType="EntityCollection"
     EntityCollectionTypeName="Fluor.Tlc.DAL.CollectionClasses.NotificationTypeCollection, Fluor.Tlc.DAL">
    </llblgenpro:LLBLGenProDataSource>
    <llblgenpro:LLBLGenProDataSource ID="dsOffice" runat="server" DataContainerType="EntityCollection"
     EntityCollectionTypeName="Fluor.Tlc.DAL.CollectionClasses.OfficeCollection, Fluor.Tlc.DAL">
    </llblgenpro:LLBLGenProDataSource>


Vs2008
v2.5
targetting oracle 9 ODP
  Top
Walaa
Support Team



Location:

Joined on:
21-Aug-2005 16:03:48
Posted:
14569 posts
# Posted on: 04-Nov-2008 11:42:36.  
Which LLBLGen Pro runtime library version are you using?

  Top
like2175
User



Location:
Camberley, United Kingdom
Joined on:
27-Mar-2006 16:16:06
Posted:
83 posts
# Posted on: 04-Nov-2008 11:57:30.  
SD.LLBLGen.Pro.ORMSupportClasses.NET20.dll reports
fileversion: 2.5.08.0328
assembly version: 2.5.0.0


Within my project the .dll reports Runtime Version v.2.0.50727


Is this what you need?
  Top
like2175
User



Location:
Camberley, United Kingdom
Joined on:
27-Mar-2006 16:16:06
Posted:
83 posts
# Posted on: 04-Nov-2008 12:11:07.  
Just noticed... Embarrassed

I have 2 projects in my solution.. The DAL and "the rest!" I was referencing 2 different version of the runtime library v2 and v2.5 in each of the 2 projects. Changing them to both reference v2.5 and closing and reopening my vs poject has fixed the issue.

Thanks for your help.

Graham


  Top
Pages: 1  


Powered by HnD ©2002-2007 Solutions Design
HnD uses LLBLGen Pro

Version: 2.1.12172008 Final.