Home
Help
Register
Log in

Search

 
   Active Threads  

You are here: Home > General > General Chat> is llblgen version 2.6 compatible with .net framework 4.0
 

Pages: 1
General Chat
is llblgen version 2.6 compatible with .net framework 4.0
Page:1/1 

  Print all messages in this thread  
Poster Message
manisha
User



Location:
india
Joined on:
01-Apr-2016 09:09:13
Posted:
1 posts
# Posted on: 01-Apr-2016 09:22:10.  
Hi,

We had to migrate our application to .net framework 4.0. and we are using LLBLGen Pro version: 2.6
but its causing errors in entity files generated by llbl gen pro. eg:

"An exception of type 'System.MissingMethodException' occurred in mscorlib.dll but was not handled in user code

Additional information: No parameterless constructor defined for this object."


i assume that it might be be because of using LLBLGen Pro version: 2.6.
can you please let me know if is llblgen version 2.6 compatible with .net framework 4.0

Thanks in advance,
manisha  Top
Otis
LLBLGen Pro Team



Location:
The Hague, The Netherlands
Joined on:
17-Aug-2003 18:00:36
Posted:
37030 posts
# Posted on: 01-Apr-2016 09:40:57.  
that's due to a breaking change with the 'Expression' class I think with linq, but as you don't give any stack trace I have to guess. Other than that it should be fine.

However as 2.6 was released in 2008, it might run into difficulties when MS decides to change something in .NET. In that case you have no other choice but to either upgrade to our latest version or compile the runtime sourcecode yourself (the sourcecode is available on disk in the install and also on the website under 'my account -> 2.6'.

We don't fix issues in v2.6 anymore.


Frans Bouma
LLBLGen Pro / ORM Profiler Lead Developer | Blog | Twitter
 
Top
Pages: 1  


Powered by HnD ©2002-2007 Solutions Design
HnD uses LLBLGen Pro

Version: 2.1.12172008 Final.